Tinderbox User-to-User Forum (for formal tech support please email: info@eastgate.com)
http://www.eastgate.com/Tinderbox/forum//YaBB.cgi
Tinderbox Users >> Moving to Tinderbox 6 >> Version 6.2 note title display problem
http://www.eastgate.com/Tinderbox/forum//YaBB.cgi?num=1429270490

Message started by Bob Kemp on Apr 17th, 2015, 7:34am

Title: Version 6.2 note title display problem
Post by Bob Kemp on Apr 17th, 2015, 7:34am

I upgraded to 6.2.0 and find that my files no longer show note titles in Map view. Titles show as normal in Outline view though. It's quite easy to fix this via the Inspector - the drop-down menus for Size, both Map and Outline, show blanks, as in no font size selected. Select a font size and the titles reappear.

However, this is tolerable in a small map but I have one or two much larger files with many nested notes, and it isn't really a practical solution in those cases. Any suggestions?

Thanks,

Bob


Title: Re: Version 6.2 note title display problem
Post by Mark Anderson on Apr 17th, 2015, 8:28am

It sounds as though you're talking about container notes. What width/size are these notes and how, if at all, did you customise the title font or its type size? also did you move from v5.12 to v6.2 or from v6.1.4 to v6.2. On the face of things, this sounds a bit odd.

Title: Re: Version 6.2 note title display problem
Post by Bob Kemp on Apr 17th, 2015, 8:57am

Thanks Mark. It's all notes, not just containers. Widths  vary. I moved from v6.1.4.

I know I have changed title font/type size in the past - enlarging the font size and changing colours - but I can't remember details. I've just done a bit of Tinderbox archaeology, examining earlier versions, and the problem manifests itself in a backup of a document from December last year. Documents since then, either later versions or other documents which use this as a template, all exhibit this behaviour. Earlier backups are fine.

Title: Re: Version 6.2 note title display problem
Post by Mark Anderson on Apr 17th, 2015, 12:03pm

So if you open them in v6.1.4 they look OK, but render differently in v6.2. After that do they still render differently v6.1.4?

Title: Re: Version 6.2 note title display problem
Post by Bob Kemp on Apr 17th, 2015, 2:25pm

They were fine in 6.1.4 and rendered differently in v6.2. I can't say what happens if I open them again in v6.1.4 because I over-wrote the older version (!). I did open them again in 5.12 and they were fine there.


Title: Re: Version 6.2 note title display problem
Post by Mark Anderson on Apr 17th, 2015, 4:18pm

Odd. Open a new [sic] tbx in v6.2.0 and look at the Document Settings, Maps tab, top-left setting which is the font and font size of map view title text. Then compare that to a file you've recovered from backup. Are they the same?

Title: Re: Version 6.2 note title display problem
Post by Bob Kemp on Apr 18th, 2015, 8:48am

No, they aren't. I have Helvetica Neue 14pt in the new doc, and Lucida Grande 12pt in the old backup

- B

Title: Re: Version 6.2 note title display problem
Post by Mark Anderson on Apr 18th, 2015, 1:40pm

Hard to diagnose further without seeing the doc. As $NameFont is a doc setting, i.e. saved into the doc at creation, opening the doc in a version with different new-doc defaults ought not to matter as the doc setting should be saved on doc initial creation and then through any subsequent user edit.

My pre-v6.2 docs with non default doc settings don't get altered on opening in v6.2.

I've just made a v6.1.3b121 new doc and the map font size is 14pt.

Title: Re: Version 6.2 note title display problem
Post by Bob Kemp on Apr 20th, 2015, 9:11am

It's curious. I was wondering if there was possibly some issue with font colour - in that if the font colour had for some reason become the same as the note it would be invisible. But the the fact that setting a font size cures the problem doesn't square with that.

[Edit] I meant to mention that new documents in v6.2 exhibit the behaviour you describe.

Title: Re: Version 6.2 note title display problem
Post by Mark Anderson on Apr 20th, 2015, 10:25am

If you open a v5.x doc in v6.x it doesn't alter the doc preferences (v5)/settings (v6). Rather v6 is drawing using a scenario where some attribute defaults may have changed and others haven't.

Whilst you may move docs back and forth from v5/6, ideally move once and stay in v6. Depending on the nature of your v5 TBX you'll likely have something to fix once only, per document, in v6. For instance, a v5 TBX with 10 notes and 5 text or view windows open will open in v6 as having 5 document windows. I think your issue here is a variant on this. It's not a bug as such but some unavoidable side-effect in changes to defaults across the to UIs; v6 is the first change in the visible interface and underlying code of Tinderbox.

Title: Re: Version 6.2 note title display problem
Post by Bob Kemp on Apr 21st, 2015, 5:38am

These points do make sense but they don't in themselves explain why I only encountered a problem when I opened documents already saved in v6.1.4 with v6.2. The assumption must be that something changed in 6.2 - not, as you say, a bug but a side-effect of a more recent change.

Anyway, I have managed to fix all my note titles in my large document and learnt something new in the process. It's probably blindingly obvious to most, but Select All at the top level in Outline really does select everything in a document, and then it's a matter of selecting an appropriate font size in the Inspector. Problem solved.

Thanks for all your efforts,

Bob

Title: Re: Version 6.2 note title display problem
Post by Mark Anderson on Apr 21st, 2015, 8:25am

As a side-note for anyone following from the sidelines, if Inspector pop-ups show a blank instead of a list item, it's an indicator that the value set/inherited for that attribute isn't one of the values in the list. Thus if a list's screen values go up in 2pt steps (12/14/16 etc.) and the note in context has a attribute value of 13pt, then the Inspector's pop-up list would show a blank.

It can be confusing at first encounter, but thereafter it's a fairly useful prompt as to stored values. If you do see a blank selection, opening the list and choosing a list item will set the selected value. so a blank doesn't stop the inspector control from being used.

Tinderbox User-to-User Forum (for formal tech support please email: info@eastgate.com) » Powered by YaBB 2.2.1!
YaBB © 2000-2008. All Rights Reserved.