Welcome, Guest. Please Login
Tinderbox
  News:
IMPORTANT MESSAGE! This forum has now been replaced by a new forum at http://forum.eastgate.com and no further posting or member registration is allowed. The forum is still accessible via read-only access for reference purposes. If you wish to discuss content here, please use the new forum. N.B. - posting in the new forum requires a fresh registration in the new forum (sorry - member data can't be ported).
  HomeHelpSearchLogin  
 
Pages: 1 2 
Send Topic Print
Bug with Inspector ? (Read 9081 times)
Graham Smith
Full Member
*
Offline



Posts: 66
Somerset, UK.
Bug with Inspector ?
Jun 02nd, 2014, 12:07pm
 
Not sure if this is the place to comment on this, but when I first open TB6,  and leave the inspector open, as I switch notes, the inspector changes to match the note I have selected.

After a few minutes, however, the inspector "sticks"on a note, and I then need to shut it down and reopen it to get it to focus on the selected note.

Once it has "stuck" I need to shut it down and reopen it, every time for it to change focus to a selected note.

Shutting the fie down and reopening it, gets the Inspector working properly again, but only for a few minutes.

Is this a known issue, or unique to me.

Cheers,

Graham

Back to top
 
 
  IP Logged
Mark Bernstein
YaBB Administrator
*
Offline

designer of
Tinderbox

Posts: 2871
Eastgate Systems, Inc.
Re: Bug with Inspector ?
Reply #1 - Jun 2nd, 2014, 1:09pm
 
If you can uncover what causes this, or send us a document where it happens, we'd be delighted to fix it for you.

We've had a few reports of this -- though none in which it occurred as often as you describe. Others don't see it at all; I haven't, and I've been using Tinderbox pretty much all day, pretty much every day.
Back to top
 
« Last Edit: Jun 2nd, 2014, 1:10pm by Mark Bernstein »  
WWW   IP Logged
Mark Anderson
YaBB Administrator
*
Offline

User - not staff!

Posts: 5689
Southsea, UK
Re: Bug with Inspector ?
Reply #2 - Jun 2nd, 2014, 1:45pm
 
FWIW, When I've (intermittently) seen this, I'm pretty sure it was in docs that had agents, though I too haven't managed to pin down a cause or get the issue to trigger on demand.
Back to top
 
« Last Edit: Jun 2nd, 2014, 2:57pm by Mark Anderson »  

--
Mark Anderson
TB user and Wiki Gardener
aTbRef v6
(TB consulting - email me)
WWW shoantel   IP Logged
Graham Smith
Full Member
*
Offline



Posts: 66
Somerset, UK.
Re: Bug with Inspector ?
Reply #3 - Jun 2nd, 2014, 2:25pm
 
Hello both,

I have emailed Mark B my file, but given how I am still fumbling about understanding TB, it could well be related to something I have done.

Cheers,

Graham
Back to top
 
 
  IP Logged
Graham Smith
Full Member
*
Offline



Posts: 66
Somerset, UK.
Re: Bug with Inspector ?
Reply #4 - Jun 3rd, 2014, 2:26am
 
As a follow up to this, I sent Mark B the file, and he couldn't replicate the problem. So at the moment, it looks like just one of those things.

I will try and see if any pattern arises when I am getting the problem.

Cheers,

Graham
Back to top
 
 
  IP Logged
David Bertenshaw
Full Member
*
Offline



Posts: 182

Re: Bug with Inspector ?
Reply #5 - Jun 5th, 2014, 11:26am
 
EDIT:

I've removed this post as the problem I was having with the inspector losing the selection and therefore not amending attributes correctly was user error.

Briefly, I confused the two inspector panels (Document Properties vs Quickstamp) -- in effect i was changing the defaults for the whole document, not attributes for selected notes.


My fault for adding confusion, sorry...
Back to top
 
« Last Edit: Jun 5th, 2014, 1:02pm by David Bertenshaw »  
  IP Logged
Graham Smith
Full Member
*
Offline



Posts: 66
Somerset, UK.
Re: Bug with Inspector ?
Reply #6 - Jun 5th, 2014, 12:23pm
 
I am being driven to an early grave with it, especially if I forget that its sticky so I will start to change things, thinking I am changing things on the selected note, when in fact I am changing things on a note I had already changed. This has been a nightmare trying to sort out the text export issues from another thread as I think I have changed the export options and I haven't

Its now sticky all the time and I need to refresh it by clicking on a tab to change to another inspector and then click back to the one I was originally using. And its happening on all the files I have created. even the many small test files with only a few notes in them.

However, what is interesting is that the tbx file that Mark has made available on that text export thread, seems to work perfectly, but none of the files I have created work.

If you read this Mark, you aren't by any chance on a 6.0.1 beta, while the rest of us are on the 6.0.0 release. Or is that just wishful thinking on my part.

Graham
Back to top
 
 
  IP Logged
Mark Anderson
YaBB Administrator
*
Offline

User - not staff!

Posts: 5689
Southsea, UK
Re: Bug with Inspector ?
Reply #7 - Jun 5th, 2014, 12:34pm
 
This issue has no favoured friends. It's driving me to distraction too. I've been testing software for years but I can see no clear trigger as to cause. hours without it then the same file, different session and it's there. Gah!

Still, our poor TB developer can't fix a problem without some idea as to the cause. Rest assured the beta testers aren't all sat relaxed behind a virtual velvet rope, we're all hand to the pump too.
Back to top
 
 

--
Mark Anderson
TB user and Wiki Gardener
aTbRef v6
(TB consulting - email me)
WWW shoantel   IP Logged
Graham Smith
Full Member
*
Offline



Posts: 66
Somerset, UK.
Re: Bug with Inspector ?
Reply #8 - Jun 5th, 2014, 12:44pm
 
Thanks Mark,

I wasn't getting at the developers or the beta testers, I am well aware of how frustrating it is to everyone when there is a problem like this.

But I was struck by the sudden revelation that "your" example file on exporting text was working perfectly where as none of "my" files are.

Cheers,

Graham
Back to top
 
 
  IP Logged
Mark Anderson
YaBB Administrator
*
Offline

User - not staff!

Posts: 5689
Southsea, UK
Re: Bug with Inspector ?
Reply #9 - Jun 5th, 2014, 1:00pm
 
Actually, my 'export' file was - at times - showing this problem. I decided that sharing that angst might not help people already frustrated by 'just' trying to export.  Smiley

The sticky problem is frustrating in that it won't reveal its method - yet.
Back to top
 
 

--
Mark Anderson
TB user and Wiki Gardener
aTbRef v6
(TB consulting - email me)
WWW shoantel   IP Logged
Graham Smith
Full Member
*
Offline



Posts: 66
Somerset, UK.
Re: Bug with Inspector ?
Reply #10 - Jun 5th, 2014, 1:07pm
 
So I have just been lucky with your export file. At least it isn't something unique to my set up.

Graham
Back to top
 
 
  IP Logged
J Fallows
Full Member
*
Offline



Posts: 418

Re: Bug with Inspector ?
Reply #11 - Jun 5th, 2014, 1:25pm
 
Quote:
Not sure if this is the place to comment on this, but when I first open TB6,  and leave the inspector open, as I switch notes, the inspector changes to match the note I have selected.

After a few minutes, however, the inspector "sticks"on a note, and I then need to shut it down and reopen it to get it to focus on the selected note.


My experience is that this is part of a small but persistent family of elusive, recurring-but-not-consistent, fit-and-finish issues that accompany the very ambitious reworking of TB6 as a whole. In my own use of the program:
  • Sometimes the inspector doesn't follow changes in focus, which is the situation you're describing;
  • Sometimes the screen doesn't update when you make changes (ie, you move an item up or down in the hierarchy, but the screen doesn't reflect that change);
  • Sometimes items won't "accept focus" at all - you click on them and nothing happens;
  • Sometimes, in an issue now being debugged, I can change a view from Outline to Map but not back again;
  • And sometimes other weird freezes or glitches happen.
In my experience none of these has ever imperiled the underlying data, and they've all been resolved by, at worst, closing and reopening the file. None of them has interfered with my using TB6 for quite a while for "real" work. I think they differ from the countless other anomalies already resolved in not yet having a consistent or obvious pattern of triggering. The hunt for these is part of the buffing and debugging now underway at Eastgate.
Back to top
 
 
  IP Logged
Prem Thomas
Full Member
*
Offline



Posts: 10

Re: Bug with Inspector ?
Reply #12 - Jun 7th, 2014, 12:45pm
 
I downloaded Mark Anderson's export demo file, and as reported above, after using it for a few minutes found the sticky inspector problem.

I'll also add one to the list of overall issues posted by J Fallows:
  • moving notes in Map view causes the entire canvas to 'jump' when a note is placed in its new location. This seems to be some sort of redrawing or rendering issue.
Back to top
 
 
  IP Logged
Steve Scott
Full Member
*
Offline



Posts: 169

Re: Bug with Inspector ?
Reply #13 - Aug 10th, 2016, 12:46am
 
J Fallows wrote:
Quote:
Sometimes the inspector doesn't follow changes in focus, which is the situation you're describing;


For me, the inspector never follows changes in focus.  It has created a great deal of grief.  I change focus, then hit command #1 2x.  

This is a new file with 2 notes. Note #2 is selected but the inspector is stuck on note 1.



Tinderbox 6.6.0
Back to top
 
 
  IP Logged
Mark Anderson
YaBB Administrator
*
Offline

User - not staff!

Posts: 5689
Southsea, UK
Re: Bug with Inspector ?
Reply #14 - Aug 10th, 2016, 3:01am
 
@Steve, do please follow up with support as well.  My own experience is the 'sticky' inspector has almost gone away. The only time I see it is if the document is has high agent/rule activity.  That's hard to quantify. I think the issue arises because there is simply too much going on in the background.  Generally, turning off agent auto-updating (File menu) and/or disabling some rules can help restore things whilst investigating the cause. It's worth bearing in mind that if several TBXs are open it might not be the current document that caused the slow down (though I'm less clear on that - it's hard to diagnose from a user perspective).

If you're seeing the problem in a small file with little/no agent or rule activity I'm sure support would like to here more detail so the cause can be diagnosed.
Back to top
 
 

--
Mark Anderson
TB user and Wiki Gardener
aTbRef v6
(TB consulting - email me)
WWW shoantel   IP Logged
Pages: 1 2 
Send Topic Print