Welcome, Guest. Please Login
Tinderbox
  News:
IMPORTANT MESSAGE! This forum has now been replaced by a new forum at http://forum.eastgate.com and no further posting or member registration is allowed. The forum is still accessible via read-only access for reference purposes. If you wish to discuss content here, please use the new forum. N.B. - posting in the new forum requires a fresh registration in the new forum (sorry - member data can't be ported).
  HomeHelpSearchLogin  
 
Pages: 1
Send Topic Print
Problem setting outline background colors (Read 1390 times)
Greg Korgeski
Full Member
*
Offline



Posts: 89
Vermont
Problem setting outline background colors
Nov 20th, 2016, 8:38am
 
I've been having a problem setting background colors for outline views. I wonder if my approach is wrong. Can any one spot the problem? I can't find this answer doing a search of the Forum so far and have been trial and erroring it.

So I may have a new outline view on an ongoing document and sometimes this happens: the background essentially goes very dark to black, and sometimes the color picking toggles and icons seem not to work well.

Generally I will control-click on the background and click the Edit Background option. The color choosing panel comes up. Generally I just try to click on the little top toggle box to change the main or top color. So the wheel or the color panel (the one with the Crayola colors and so on) comes up. I pick a color. Sometimes it works. Sometimes the screen top (working with a radial gradient usually) just goes to a black. Now I've a few times fixed this using the second top box with the "gray scale slider" but other times nothing moves or happens. Sometimes I use other toggles and such, but again, nothing moves or even if it does, it just goes dark again.

Am I even working at this the right way? What might I be missing?

Thanks! Sorry if this has already been addressed incessantly or in places I should have tried first. Thanks for your help.
Back to top
 
 
  IP Logged
Mark Anderson
YaBB Administrator
*
Offline

User - not staff!

Posts: 5689
Southsea, UK
Re: Problem setting outline background colors
Reply #1 - Nov 20th, 2016, 10:43am
 
What version of the app and OS are you using?
Back to top
 
 

--
Mark Anderson
TB user and Wiki Gardener
aTbRef v6
(TB consulting - email me)
WWW shoantel   IP Logged
Mark Bernstein
YaBB Administrator
*
Offline

designer of
Tinderbox

Posts: 2871
Eastgate Systems, Inc.
Re: Problem setting outline background colors
Reply #2 - Nov 20th, 2016, 12:13pm
 
Works fine for me.  

How about choosing one of the named colors?
Back to top
 
 
WWW   IP Logged
Greg Korgeski
Full Member
*
Offline



Posts: 89
Vermont
Re: Problem setting outline background colors
Reply #3 - Nov 20th, 2016, 4:01pm
 
Hi guys. All up to date. TBX 6.6.5 and Mac OS 10.12.1 on a brand new Macbook Pro. To tell the truth, I had been holding off on sending a question in because I'd been using some old hardware, just in case. But the problem still occurs.

I do try named colors including the ones that can toggle down as well as the standard color picker (e.g. the "Crayola") colors.

Like I think I said, it doesn't always happen. And I can't make it happen readily on a new document. But it occurred today on tests on several documents, each of which were a few years old. I tried a few as I thought maybe there was something weird buried in one of them somewhere... still seemed to occur. At the same time, I also one time did get a color where I wanted it.(I can't recall what was different about the trial when I did that. But I had started this request already and toggling back and forth to try to describe things, somehow it got fixed, so I discarded the post.) But then wanted to work inside one of the contents of that one as a second list to work on without clutter, disliked the color, thought I could fix it again... and the problem occurred again.

It does really look like the results you get when the grayscale slider is all the way dark, or nearly so. Yet, moving that back and forth does not seem to help and a few times, it would not move, depending.

Puzzling. If you don't have any obvious ("e.g., people always miss this") sorts of ideas, that's okay. I might fix it eventually. Thought maybe something obvious was hanging me up.

Thanks.
Back to top
 
 
  IP Logged
Mark Bernstein
YaBB Administrator
*
Offline

designer of
Tinderbox

Posts: 2871
Eastgate Systems, Inc.
Re: Problem setting outline background colors
Reply #4 - Nov 21st, 2016, 10:09am
 
No; I meant: try Tinderbox named colors like "red", "dark blue", etc.
Back to top
 
 
WWW   IP Logged
Greg Korgeski
Full Member
*
Offline



Posts: 89
Vermont
Re: Problem setting outline background colors
Reply #5 - Nov 21st, 2016, 11:43am
 
I think so, in that if I toggle the top line of the color panel, I see "normal/custom" and then a long string of Tinderbox-named colors and such. That what you mean? Those do still work the same way sometimes. I may switch to "teal" or something and it will still be heavy on the gray scaling. And like I said, sometimes that adjusts back from the slider if I open it (clicking on the little color box), but there have been times it did not.

I'll keep hunting around. If I wanted to open the inspector and just mess with the attributes directly, how to do that for an individual outline view like this, where the document may have several or more such outline views depending on the area I'm working in? I assume that is controlled as an attribute of the topmost (container) note... not sure the attribute for the background coloration for that note if it is the top container in an outline view. I could try that.

Thanks again.
Back to top
 
 
  IP Logged
Mark Bernstein
YaBB Administrator
*
Offline

designer of
Tinderbox

Posts: 2871
Eastgate Systems, Inc.
Re: Problem setting outline background colors
Reply #6 - Nov 21st, 2016, 12:03pm
 
I've spent a ton of time trying to reproduce this, and outline colors work fine.

If trouble persists, please send sample document and details to bernstein@eastgate.com
Back to top
 
 
WWW   IP Logged
Greg Korgeski
Full Member
*
Offline



Posts: 89
Vermont
Re: Problem setting outline background colors
Reply #7 - Nov 25th, 2016, 9:41pm
 
Thanks for trying, Mark. I'll send it on. G
Back to top
 
 
  IP Logged
Greg Korgeski
Full Member
*
Offline



Posts: 89
Vermont
Re: Problem setting outline background colors
Reply #8 - Dec 24th, 2016, 12:33pm
 
Just to follow up and get some closure on this color thing. We could not figure it out and so I sent in a support request with a copy of a document that was giving me problems. Initially Mark could not replicate it. I later sent in another document where the color I sent would turn to black when I clicked on the note in Map view. I added a screen recording of what would happen.

Mark looked at these and did manage to reproduce the problem. He sent this reply, and agreed that I might post it here as closure for this thing. Apparently it was not clear why this would occur but it was real (I may be crazy but not about this...) anyway, it will be fixed (somehow) in the next release. Here is Mark's reply. Happy holidays, all.

I can reproduce this on 6.6.5, but its fixed in the current backstage release. I'm not entirely sure what the underlying issue was, but I think it's been cleared up.

Workarounds:

      use named colors instead of the color well
      close the color picker after choosing the color
      use the backstage release, taking care to keep superb backups since this is test software.
Back to top
 
 
  IP Logged
Pages: 1
Send Topic Print