Welcome, Guest. Please Login
IMPORTANT MESSAGE! This forum has now been replaced by a new forum at http://forum.eastgate.com and no further posting or member registration is allowed. The forum is still accessible via read-only access for reference purposes. If you wish to discuss content here, please use the new forum. N.B. - posting in the new forum requires a fresh registration in the new forum (sorry - member data can't be ported).
Pages: 1
Send Topic Print
Finding prototypes (Read 1499 times)
Ellen Madono
Full Member

Posts: 90

Finding prototypes
Dec 02nd, 2016, 3:49pm
I have very irritating copies of prototypes lost in my tbx project.  They are cluttering up my list so I want to find them and get rid of them.

You explained this to me before, Mark, but the prototype did not appear in the agent box.    In the past,I think it did once or twice, then it didn't work.  I know capitalization sensitive is one reason. (I also tried unchecking the capitalization sensitive box in the inspector view/query.) That is not the cause.  What else could I have done?

By the way, I can't figure out how to send photos and I am going to wait until the new forum is working assuming it is easier.

I watched Steve Zeroli's excellent video and I have a better idea of how the agent works, but something is missing in my understanding.


What happened

The agent seems to work once.  Then when I change the name, it no longer works.

Was   $IsPrototype & $Name=="Water"  That worked.

Now is
$IsPrototype & $Name=="Phlegmatic"  That does not work in map view.


That is nothing appears in the map view inside the agent box.  One difference  between my first  successful attempt and the second  unsuccessful attempt  is there are many  boxes name "Phlegmatic"  that I want to  get rid of.    There is only one box named "Water". Undecided
Back to top
  IP Logged
Mark Anderson
YaBB Administrator

User - not staff!

Posts: 5689
Southsea, UK
Re: Finding prototypes
Reply #1 - Dec 2nd, 2016, 4:14pm
If the query $IsPrototype & $Name=="Phlegmatic" returns nothing you don't have a prototype called "Phlegmatic" even if you do have notes titled "Phlegmatic".

Before going down a rabbit-hole of presumptions, try this and post a list of the names of all the notes listed in the pop-up. given the result of your agent, as described, we would not expect to see "Phlegmatic" listed.

As I recall, Tinderbox trims white space on new $Name values. But it may be you've a prototype called " Phlegmatic" or "Phlegmatic " and an unexpected space may be the issue, as a == query will not match either of the preceding variants. This should:

$IsPrototype & $Name.contains("Phlegmatic")
Back to top

Mark Anderson
TB user and Wiki Gardener
aTbRef v6
(TB consulting - email me)
WWW shoantel   IP Logged
Pages: 1
Send Topic Print